PSP Audioware

PSP Audioware - PSP 2445

PSP 2445 EMTis a reverb processor plug-in (VST, and AAX for Windows; AudioUnit, VST, and AAX for Mac OSX) inspired by two legendary early digital age reverberators: the EMT® 244 and the EMT® 245. PSP thoroughly researched how to bring the specific features of those simple, yet very musical sounding reverbs to life as a plug-in.

We then improved from the originals with a handy set of parameters to control details of the sound and mix the reverb not available in the original hardware. The PSP 2445 is capable of processing using one selected engine or both of them simultaneously.

The reverb algorithms implemented in PSP 2445 are based on original algorithms designed by Dr. Barry Blesser (one of the grandfathers of the digital audio revolution). Thanks to Barry’s extensive consultation and support our algorithms sound as good as the originals and plug-in could be officially endorsed by EMT Studiotechnik GmbH.

The PSP 2445 EMT immediately found its way into my productions and mixes. My favorite reverbs hug the track in a way that is supportive and not distracting. Using this plug-in feels like I have the EMT units in the equipment room. Rich, complex and dense, this reverb plugin lives permanently in my mix template.

Greg Wells,record producer, songwriter, musician, and mix engineer
Celine Dion, Katy Perry, Adele, Pharrell Williams, Rufus,  Timbaland, Pink ...

The PSP 2445 is an exceptional reverb plugin. I remember seeing the original in all the mastering rooms. It was a really high quality verb that few could afford. The depth and natural decay of the PSP 2445 plugin is impressive. They matched perfectly the original and actually I think they improved it. It's no surprise, I love so many of their other plugins.

Michael Brauer, legendary multiple Grammy winning mix engineer
Coldplay, John Mayer, Aretha Franklin, Bob Dylan, The Rolling Stones ...

____________________________________________
System Requirements

Windows

VST

  • Windows 7, 8 or 10
  • VST 2.4 compatible application
  • Up to date (at least version 3.1.7)

AAX

  • Windows 7, 8 or 10
  • Pro Tools 10, 11, 12 (or later)
  • Up to date (at least version 3.1.7)

 

Mac (intel)

AudioUnit

  • Mac OSX 10.8 - 10.12 or later
  • 32 or 64-bit host application capable of running AudioUnit plug-ins with Cocoa view
  • Up to date (at least version 3.1.7)

VST

  • Mac OSX 10.8 - 10.12 or later
  • 32 or 64-bit VST 2.4 compatible host application
  • Up to date (at least version 3.1.7)

AAX

  • Mac OSX 10.8 - 10.12 or later
  • Pro Tools 10,11,12 or later
  • Up to date (at least version 3.1.7)

Customer Reviews

No reviews yet
0%
(0)
0%
(0)
0%
(0)
0%
(0)
0%
(0)

Customer Reviews

No reviews yet
0%
(0)
0%
(0)
0%
(0)
0%
(0)
0%
(0)