Skip to content
Earn 10% in Reward Points on Every Purchase!
Earn 10% in Reward Points on Every Purchase!

MeldaProduction - MAmp

Electronic Download
No shipping required, software license is emailed within minutes.
Please note software is not eligible for returns or cancellation once purchased.
Ask us about compatibility & system requirements before purchasing.
Original price $45.00 - Original price $45.00
Original price
$45.00
$45.00 - $45.00
Current price $45.00

Vintage Amp

MAmp is a great sounding vintage amp. Whether you are looking for a soft saturation to enhance the harmonic content or a great sounding creative distortion, MAmp is the right tool for the job.

MAmp employs the famous distortion algorithm from MVintageRotary, which is inspired by the vintage analogue components, but is not limited by that technology. With several additional features courtesy of digital processing!

Looking for a little extra variation in your sound? Maybe you want the rotary to switch from slow to fast and back automatically, or you want more distortion when you play louder? This and much more is made easy using our incredible modulators.

Features

  • High quality analog simulation
  • Modulation heaven
  • Advanced GUI
  • Tube saturation
  • Unique visualisation engine with classic meters and time graphs
  • Modulators
  • Multiparameters
  • Smart randomization
  • Automatic gain compensation (AGC)
  • Safety limiter
  • M/S, single channel, up to 8 channels surround and up to 64 channels ambisonics processing...
  • Multiparameters
  • MIDI controllers with MIDI learn
  • Adjustable up-sampling 1x-1024x
  • Global preset management and online preset exchange
  • No dongle nor internet access is required for activation

_________________________________________
System Requirements

Protection Type
  • Serial Number (no Dongle required)
Windows Requirements
  • Host application compatible with:
    • AAX Native plugins
    • VST plugins
    • VST3 plugins
  • Windows 8 / 10 / 11 (32-bit or 64-bit)
  • VST / VST3 / AAX compatible host (32-bit or 64-bit)
  • Intel/AMD processor with SSE2 support
Mac Requirements
  • Host application compatible with:
    • AAX Native plugins
    • Audio-Unit plugins
    • VST plugins
    • VST3 plugins
  • MacOS 10.14 and newer (64-bit)
  • VST / VST3 / AU / AAX compatible host
  • Intel/AMD/M1 processor with SSE2 support
  • M1 (native Apple Silicon ARM CPU) support

Customer Reviews

Be the first to write a review
0%
(0)
0%
(0)
0%
(0)
0%
(0)
0%
(0)