Sale

Softube

Softube - Weiss Compressor/Limiter

The mastering stage is the last chance to make or break a track, so getting it right can be the difference between a battle won or lost. With such small tolerances, it’s here that the quality of your tools matters most. Enter the new Weiss Compressor/Limiter.

The Modern and Transparent Mastering Compressor/Limiter
The name Weiss is synonymous with quality in mastering, and a truly exceptional compressor/limiter is essential to any serious mastering engineer.

Earlier this year Softube brought the Weiss DS1-MK3 digital dynamics processor, the top-of-the-line go-to for a huge proportion of the world’s greatest mastering gurus, into the software realm.

Now, with the Weiss Compressor/Limiter, the DSP-happy Swedes draw on its essence (and code-base) to bring a totally focused and fit-for-purpose modern answer to the question ‘how should I deal with dynamics on my mix bus?’

The startling transparency and effectiveness of the Weiss digital compression algorithms in the Compressor/Limiter, and its unrivalled versatility in terms of detailed control over attack and release times, knee settings, ratio, threshold, filters (low pass and band pass), and other crucial factors, make the product a must-have.
 
And that’s before even mentioning the cutting-edge graphical visualizations – users will be able to see in detail the precise effect they’re having on their signal, allowing them to know their material better and make the right calls with a degree of precision and detail that even the very best ears can’t promise.

_____________________________________________

System Requirements
Versions from 2.0 and newer of the Softube plug-ins have the following minimum requirements:

All native versions

  • Mac OS X 10.9 or newer
  • Windows 64-bit, versions 7, 8 or 10
  • Intel Core 2 Duo, AMD Athlon 64 X2 or newer
  • Screen resolution larger than 1280x800
  • 1 GB RAM or more, and at least 6 GB hard disk space for installation (individual plug-ins take less space)
  • Any VST, VST3, AU, or AAX (Pro Tools 10.3.7, 11.0.2 or higher) compatible host application
  • Please Note: Pro Tools 10 is not officially qualified by Avid higher than OS X 10.8
  • Softube/Gobbler account
  • iLok account
  • Internet access for downloading installer and managing licenses
  • iLok generation 2 and up, if you intend to use an iLok dongle for authorizing your plug-ins (note that an iLok dongle is not a requirement)

All Softube plug-ins support both 32- and 64-bit hosts, although a 64-bit OS is required. Supported sample rates: 44.1, 48, 88.2, 96, 176.4 and 192 kHz, in both mono and stereo.

Customer Reviews

No reviews yet
0%
(0)
0%
(0)
0%
(0)
0%
(0)
0%
(0)
Sign up for our newsletter!